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1 Disclaimer 
This document is for informational purposes only. Its content is subject to change without notice, 
and SAP does not warrant that it is error-free. SAP MAKES NO WARRANTIES, EXPRESS OR 
IMPLIED, OR OF MERCHANTABILITY, OR FITNESS FOR A PARTICULAR PURPOSE.  

The information contained in this document represents SAP's current view of accessibility crite-
ria as of the date of publication; it is in no way intended to be a binding guideline on how to en-
sure accessibility of software products. SAP specifically disclaims any liability with respect to 
this document and no contractual obligations or commitments are formed either directly or indi-
rectly by this document. This document is for internal use only and may not be circulated or 
distributed outside your organization without SAP's prior written authorization. © 2009 SAP AG 

2 General Statements about Platforms 
Our efforts in the accessibility program are currently focused on the following front-end/client-
platform environment.  

2.1 Operating System 

The following operating systems are supported: 

• Windows 2000 

• Windows XP 

• Windows 2003 (also known as Windows XP Server) 

2.2 Web Browser  

The following Web browser is supported:  

• Microsoft Internet Explorer 6  

2.3 SAP GUI for Windows 

SAP GUI for Windows is the standard GUI for applications based on the ABAP/Dynpro envi-
ronment. The following SAP GUI version is required for applications based on ABAP Dynpro:  

• SAP GUI for Windows 7.10 (or higher) 

The latest version of SAP GUI for Windows is available as DVD files on SAP Service Market-
place at http://service.sap.com/installations → Entry by Application Group → SAP Frontend 
Components → SAP GUI for Windows→ SAP GUI for Windows 7.10 Core. The most up-to-date 
patches are available at http://service.sap.com/patches → Entry by Application Group → SAP 
Frontend Components → SAP GUI for Windows→ SAP GUI for Windows 7.10 Core. SAP GUI 
for Windows 7.10 is also available on DVD through the usual channels. If you want to install a 
new SAP GUI for Windows on your client PC, you must first download the DVD files, install 
SAP GUI, and then install the latest patch. 

2.4 SAP Interactive Forms by Adobe 

To display SAP Interactive Forms by Adobe, you require the latest version of Adobe Reader. 
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2.5 Screen Readers 

SAP does not provide screen readers; these technologies must be acquired separately.  

The following screen readers work with SAP GUI for Windows: 

• JAWS® for Windows by Freedom Scientific®, Version 9.0 

Details about the supported JAWS for Windows versions are available in SAP Note 988421. 

• Screen readers certified by SAP (such as Virgo 4.71 by BAUM Retec AG) 

More information about screen readers certified by SAP is available at 
http://www.sap.com/partners/directories/SearchSolution.epx. On this page, select the entry "BC-
SCR-GUI 6.4W" in the SAP-Defined Integration Scenarios field and start a search. Be aware 
that each screen reader differs in the scope of functions it offers. 

By exposing the SAP GUI object model, SAP has met the technical requirements for screen 
readers to work together with SAP GUI for Windows. 

3 Recommendations for ABAP-Based Applications 
SAP recommends SAP GUI for Windows 7.10 or higher for ABAP-based applications.  

This system landscape covers only some of the accessibility requirements, however, and you 
also need to perform the further activities described in this document.  

3.1 Recommended Settings in SAP GUI for Windows 

The settings for the accessible use of SAP GUI for Windows include the accessibility mode 
setting under SAP Configuration, which you can access in the Windows Control Panel, and 
some settings in the SAP GUI options dialog. 

To support screen readers based on SAP GUI scripting, SAP GUI scripting must be activated 
on the application server. More information is available in SAP Note 480149. SAP Service Mar-
ketplace provides you with more information about SAP GUI scripting and security-related ques-
tions at http://service.sap.com/sapgui → SAP GUI Scripting. 

The following table shows you the recommended settings in SAP GUI for Windows according to 
the type of assistive technology used or the type of disability. The settings are described in more 
detail further below. 

 
Type of Setting Screen reader 

users 
Screen 
magnifier users 

Users with 
visual 
impairments 
who do not use 
assistive 
technologies 

Users with 
motor 
impairments 

Accessibility 
mode (SAP 
Configuration) 

Switch on Switch on Switch on Switch on 

Notify when a 
script attaches 
to a running 
SAP GUI (SAP 
Configuration) 

Switch off Not relevant Not relevant Not relevant 
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Type of Setting Screen reader 
users 

Screen 
magnifier users 

Users with 
visual 
impairments 
who do not use 
assistive 
technologies 

Users with 
motor 
impairments 

Include inactive 
elements in tab 
chain (SAP GUI 
options dialog) 

Switch on Switch on only if 
preferred 

Switch off Switch off 

Display list 
symbols as 
letters (SAP GUI 
options dialog) 

Switch on Switch off Switch off Switch off 

Dialog box for 
messages 
(SAP GUI 
options dialog) 

Switch on Switch on Switch on only if 
preferred 

Switch off 

Set F4 help to 
modal dialog 
(SAP GUI) 

Switch on Switch on only if 
preferred 

Switch on only if 
preferred 

Switch off 

3.1.1 Settings in the SAP Configuration 

For accessible use of SAP GUI for Windows, SAP recommends the following settings in SAP 
Configuration. 
1. In Windows Control Panel, choose SAP Configuration. 

2. In the SAP Configuration dialog box, deselect the Use New Visual Design flag. 

3. In the SAP Configuration dialog box, select the Use Accessibility Mode flag. 

4. If your assistive technology uses a script, deselect the Notify when a script attaches to a 
running SAP GUI flag in the SAP Configuration dialog box. (This setting is not relevant if 
you do not use an assistive technology.) 

More information about this option and about security is available in the Security Guide for 
SAP GUI Scripting on SAP Service Marketplace under http://service.sap.com/sapgui → 
SAP GUI Scripting → Security Considerations and Requirements. 

3.1.2 Settings in the SAP GUI for Windows Options Dialog 

You can make the settings recommended in the table above in the SAP GUI for Windows op-
tions dialog as follows: 

1. Choose Local Layout → Options in the menu. You can also use the key combination [ALT] 
+ [F12] (for Local Layout) and then press the key [o] (for Options). 

2. On the Options tab page, select Dialog box at error message and Dialog box at warning 
message. If you also want to display dialog boxes for success messages and play beeps for 
messages, set the appropriate options. (We recommend that users of screen readers or 
screen magnifiers use this setting.) 

3. You can reset the following accessibility mode properties to their defaults by deselecting the 
appropriate options on the Accessibility tab page in the options dialog: 
o Include disabled elements in tab chain 
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You use this flag to include inactive elements in the tab chain (which makes them ac-
cessible using the tab key). 

o Display list symbols as letters 

You use this flag to specify whether the SAP GUI list symbols (such as the symbol for 
opening or closing a tree node) are displayed as alphanumeric characters or as sym-
bols. You only need to set this flag if you use an assistive technology that is not com-
patible with the SAP Symbol font. 

Deselect these two options only if you do not need the information they provide. More in-
formation is available in SAP Note 883706. 

3.1.3 F4 Help Settings in SAP GUI for Windows 

In SAP GUI for Windows, choose Help → Settings. On the F4 Help tab page, set the F4 help 
display to Dialog (modal). This setting displays the input help in SAP GUI in a dialog box instead 
of in a search help UI element. 

3.1.4 Font Settings and Color Customizing in SAP GUI for Windows 

In SAP GUI for Windows you can tailor the font, its size and color, and the background color to 
meet your requirements for specific parts of the application. You must first select accessibility 
mode for SAP GUI for Windows (as described in section 3.1.1). More information is available in 
the SAP accessibility documentation under Settings in SAP GUI for Windows for Users with 
Visual Impairments.  

To enable the minimum contrast in SAP GUI for Windows, we recommend to use the color 
scheme Windows Classic within Windows operating system. 

Color Customizing in Operating System Windows 

Among others, the color display in Accessibility Mode of SAP GUI for Windows depends on the 
color customizing in operating system Windows.   

For users, who need a minimum luminosity contrast 4.5:1, we recommend the usage of the 
color scheme Windows Classic in Windows. 

For users, who need a high contrast black display with black background color and white fore-
ground color, we recommend the usage of the color scheme High Contrast Black in Windows.  

3.1.5 SAP NetWeaver Application Server ABAP (Back End) 

Accessibility mode in SAP GUI for Windows is located locally on your host, which means that 
you do not usually need to make any changes to the server configuration of SAP NetWeaver 
Application Server ABAP when using assistive technologies.  

One exception to this, however, is technologies that are based on the SAP GUI scripting inter-
face, with the underlying security concept of this interface being particularly relevant. The main 
additional requirement is that the profile parameter sap-gui/user_scripting must be set to TRUE 
in SAP systems. The system administrator can do this in transaction RZ11 (Profile Parameter 
Maintenance) or in the initialization file of the application server. Documentation about this pro-
cedure and the SAP GUI scripting security concept is available on SAP Service Marketplace at 
http://service.sap.com/sapgui → SAP GUI Scripting. Technical details and information about 
any updates are available in SAP Note 480149. 

4 Recommendations for Other Web-Based Applications 
For Web applications not based on ABAP technology, HTML output is generated directly using 
SAP NetWeaver Application Server (Release 2004 or higher).  
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Alongside the operating system and Web browser mentioned in this document, there are also 
other recommendations for the front-end infrastructure.  

4.1 Web Browser for Portal and Web Dynpro Applications 

To support the accessible use of HTML-based applications within SAP NetWeaver (such as the 
portal, Web Dynpro, BSP, and HTMLB-based applications), we recommend that you make the 
settings described in this section. The settings involved also depend on the requirements of the 
individual user.  

4.1.1 Special Software Requirements  

We recommend Microsoft Internet Explorer 6 as a Web browser. You can keep the defaults in 
this browser since no further settings are required in Internet Explorer itself. 

4.1.2 Activating Accessibility Mode  

Either the user or a system administrator can enable support for accessibility mode. All applica-
tions and the portal run in accessibility mode once it has been enabled. This setting can also be 
enabled for applications that do not run in the portal but in their own browser instance. This is 
done using a URL parameter (as shown in method 3 below).  

• Method 1: The portal user activates accessibility mode. 

The user can activate or deactivate accessibility mode for the portal and its applications as 
follows: 

In the Portal, choose Personalize → User Profile and select or deselect the Activate Acces-
sibility Features (Screen Reader Required) checkbox.  

"Screen Reader Required" just indicates that this setting activates support for screen read-
ers and does not require you to activate any screen reader you have installed. This flag is 
not just relevant for users who use screen readers, but also for users who want to work in 
accessibility mode without screen readers. 

• Method 2: The portal administrator activates accessibility mode. 

The portal administrator can also enable accessibility mode for individual users. This can be 
done when the administrator creates a new user in User Management Administration Con-
sole by choosing User Administration → Users → Create User. It is also possible when dis-
tributing roles in SAP User Management Engine (UME). More information is available in the 
SAP portal documentation. 

• Method 3: Enabling accessibility mode without the portal 

If you want to run, for example, the Web Dynpro application in a Web browser outside of the 
portal, a dedicated URL parameter exists for enabling accessibility mode. Add the following 
parameter to the end of the application URL:  

?sap-accessibility=x 

Example: 

http://appserver:50000/webdynpro/dispatcher/myappdir/myapp?sap-accessibility=x 

4.1.3 Font Settings and Color Customizing for the Portal 

Support for different color schemes, fonts, and font sizes is provided by assigning a different 
visual theme within the portal. A chosen theme also involves the definition of colors, fonts, and 
font sizes. You can use Theme Editor to modify a theme to meet different user requirements. 
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You can also set the font size for a theme to one of five levels in the web browser. To do this, 
choose View → Font Size in Microsoft Internet Explorer and select one of the options. If you 
want the font to be larger, we recommend that you use a screen magnifier. Another option is to 
copy the theme shipped by SAP and modify this copy. 

A range of themes are available, including high contrast themes with black backgrounds and 
white fonts. There are two ways of assigning themes to a user: 

• Method 1: The portal user selects the theme. 

The user can switch the theme for the portal and any applications running in it. To do this, 
choose Personalize → Portal Themes and select a new theme. If a preferred theme is not 
available, the portal administrator can create an individual theme (as shown in method 2).  

• Method 2: The portal administrator assigns the theme or creates a new theme. 

The portal administrator can assign a different theme to a user when asked. The new theme 
is assigned to the user when the portal desktop is assigned and is subject to the display 
rules from the portal role collection. 

If a preferred theme is not available, the portal administrator can create an individual theme 
in Theme Editor. To do this, choose System Administration → Portal Display → Theme Edi-
tor (in the administrator role). To enable the user to select a new theme, the portal adminis-
trator must assign this theme to the portal desktop used by the user. 

More information is available in the SAP portal documentation.  

5 Recommended Settings in Adobe Reader 7 
You can configure Adobe Reader to appear in the Web browser (an integrated display) or in its 
own window (standalone mode). When you work in accessibility mode, you must make one of 
the following recommended settings in Adobe Reader to preview SAP Interactive Forms by 
Adobe, depending on the technology you use.  

We recommend standalone mode when you use the following technologies:                                                            

• SAP GUI for Windows  

• Web Dynpro applications, if the forms are not based on ZCI technology. (ZCI stands for 
Zero Client Installation.)  

We recommend the integrated display when you use the following technologies:  

• Web Dynpro applications, if the forms are based on ZCI technology. This applies to Release 
SAP NetWeaver 7.0 Support Package 08 and above.  

You can make this setting in Adobe Reader as follows:  

1. In the Adobe Reader menu, choose Edit → Preferences.  

2. In the Preferences dialog box, choose the Internet category.  

3. If you want to display Adobe Reader in your Web browser (integrated display), select the 
Display PDF in Browser flag. Similarly, if you want to run Adobe Reader in standalone 
mode, deselect this flag. 

6 Recommended Settings in JAWS for Windows 9.0 
Details about the supported versions of JAWS® for Windows by Freedom Scientific® are avail-
able in SAP Note 988421. As an example, the following sections describe the recommended 
settings for Version 9.0 of JAWS for Windows. Details about the recommended settings for 
JAWS for Windows when used with SAP products are also available in SAP Note 995251. 

© 2009 SAP AG Title: Front-End Requirements and Infrastructure for Accessibility Page 9 of 12
Dietmar-Hopp-Allee 16 
D-69190 Walldorf, 
Germany 

Version: 4.3, Date: May 14, 2009 
SAP CUSTOMER INFORMATION 

 

https://websmp130.sap-ag.de/sap(bD1kZSZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=0988421&nlang=E
https://websmp130.sap-ag.de/sap(bD1kZSZjPTAwMQ==)/bc/bsp/spn/sapnotes/index2.htm?numm=0995251&nlang=E


 

6.1 Using JAWS 9.0 with SAP GUI for Windows 

To use the JAWS for Windows screen reader with SAP GUI for Windows, you must install the 
SAP GUI Screenreader Extension (provided by SAP) on your client PC. More information is 
available in SAP Note 740785 and SAP Note 1023085. SAP provides this extension for free and 
it is included in SAP's standard shipment. The extension is located on Presentation CD 1 in the 
directory Screen_Reader_Extension and is available in Compilation 2 of Release 7.10 and 
above. You can also download this extension from SAP Service Marketplace at 
http://service.sap.com/patches. On this page, choose Entry by Application Group → SAP Fron-
tend Components → SAP Screenreader Extensions → SAP Screenreader Extensions → 
Win32. To install the extension, start the executable file on your client PC. Note that SAP GUI 
Screenreader Extension does not work in a terminal server environment.  

To activate SAP GUI Screenreader Extension for the screen reader, enable SAP GUI scripting 
on the application server (see section 3.1.5).  

When you use JAWS for Windows with SAP GUI for Windows, we recommend that you set the 
options listed in the following table in JAWS Configuration Manager. 

Note: When you use the key combination [insert]+[6], to start JAWS Configuration Manager 
from an application, JAWS loads the configuration manager with this application's profile. For 
this reason, use the key combination [insert]+[6] to start JAWS Configuration Manager from the 
open SAP GUI for Windows window. The profile file for SAP GUI for Windows is 
SAPFRONT.JCF. 

Options Settings 
Verbosity Options Tool tips are enabled. 

Set this option in the beginner, intermediate, and 
advanced preferences. 

Cursor Options Notify when cursor changes shape 
If the SAP system is running in the background, the 
cursor changes its shape to signalize a waiting state. 
If this setting is activated, you are notified when the 
SAP system ends its waiting state. 

Braille Options Structured mode is activated. 
SAP GUI Screenreader Extension supports only 
structured mode for JAWS. 

6.2 Using JAWS 9.0 with the Portal and with Web Dynpro Ap-
plications 

We recommend the following settings in JAWS Configuration Manager when using JAWS for 
Windows with HTML-based applications in SAP NetWeaver (such as the portal, Web Dynpro, 
BSP, and HTMLB-based applications). These options are listed in the following table. 

Note: When you use the key combination [insert]+[6], to start JAWS Configuration Manager 
from an application, JAWS loads the configuration manager with this application's profile. For 
this reason, use the key combination [insert]+[6] to start JAWS Configuration Manager from the 
open Web browser window. 

Options Setting 
Advanced Options Virtual PC Cursor is disabled. 

This setting is mandatory when using JAWS  in 
HTML-based applications in SAP NetWeaver (such 
as the portal, Web Dynpro, BSP, and HTMLB-based 
applications). 
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Options Setting 
HTML Options Custom search string containing the following is 

activated for graphics:  
title|alt|src  
Custom search string containing the following is 
activated for links:  
title|alt|src|href 

Verbosity Options Tool tips enabled in the beginner, intermediate, and 
advanced preferences. 
Set this option in the beginner, intermediate, and 
advanced preferences. 

Cursor Options Notify when cursor changes shape 
If the SAP system is running in the background, the 
cursor changes its shape to signalize a waiting state. 
If this setting is activated, you are notified when the 
SAP system enters or ends its waiting state. 

The virtual PC Cursor must be disabled when using JAWS  in HTML-based applications in 
SAP NetWeaver (such as the portal, Web Dynpro, BSP, and HTMLB-based applications). The 
open concept of the portal can require you to navigate to the virtual PC Cursor for other applica-
tions or external content. JAWS provides a key combination that quickly enables or disables the 
virtual PC Cursor: You can enable or disable the virtual PC Cursor for the duration of a JAWS 
session by pressing the [y] key twice while keeping the [insert] key pressed. This means you do 
not have to access the advanced options of JAWS Configuration Manager. If you are not sure 
which mode you need, first try your application with the virtual PC Cursor disabled. This is the 
default mode for navigation. 

6.3 Using JAWS 9.0 with SAP Interactive Forms by Adobe 

The virtual PC Cursor is of central importance when you use JAWS and PDF forms. You can 
use Form Mode in JAWS to fill out form fields. More information and helpful key combinations 
are available in the JAWS help documentation. JAWS generally enables the virtual PC Cursor 
by default when you open a PDF document. We recommend that you start JAWS first and then 
open a form. The virtual PC Cursor in JAWS is enabled as soon as the form is opened. 

 

6.4 Using JAWS 9.0 with SAP CRM 

We recommend the following HTML Options settings in JAWS Configuration Manager when 
using JAWS for Windows with SAP CRM 2006s (or higher) 

 
HTML Options Setting 
Graphics > Graphics Options Use Longest 
Link > Text Link Options Use Longest 
Misc > Form Field Prompt Options Use Both Label And Title If Different 
Misc >Button Text Options Use Longest 

 

© 2009 SAP AG Title: Front-End Requirements and Infrastructure for Accessibility Page 11 of 12
Dietmar-Hopp-Allee 16 
D-69190 Walldorf, 
Germany 

Version: 4.3, Date: May 14, 2009 
SAP CUSTOMER INFORMATION 

 



 

7 Recommended Settings in Virgo 4.71 

7.1 Using Virgo 4.71 with SAP GUI for Windows 

To use the Virgo screen reader by BAUM Retec AG with SAP GUI for Windows, you require 
Virgo Version 4.71. If you have any questions about Virgo, contact info@baum.de.  

Install the latest SAP GUI for Windows patch on your client PC to make sure that you are work-
ing with the latest Virgo 4.71 scripts. 

SAP GUI scripting must also be enabled on the application server (see section 3.1.5).  

If SAP GUI scripting is enabled on the application server, you activate the new scripting in Virgo 
4.71 by using the key combination [caps lock] + [shift] + [F5]. Once you have confirmed the 
prompt, Virgo uses a version that is based on SAP GUI scripting. This is indicated by the 
speech synthesizer or refreshable Braille display reading out the text "EF [Erfo] User" from the 
SAP Logon (via the screen reader). The text indicates that the object model can be accessed. 

If SAP GUI scripting is not activated on the application server, Virgo uses a version that is not 
based on SAP GUI scripting. We do not recommend this, since Virgo will not then receive the 
extra information provided by SAP GUI scripting. 
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